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1 Netop Vision Pro 

This guide is for teachers who are used to working with Netop School in their 

teaching and are now migrating to Vision1. The two classroom management solutions 

share many features but there are also fundamental differences.  

This guide explains: 

 How to install Vision. 

 Which settings can be automatically imported from Netop School. 

 How to set up a classroom. 

 Where to find the most frequently used commands in Vision. 

 The last section is a complete list of Netop School commands with their 

equivalent Netop Vision Pro command. 

2 Install Vision 

The Vision installation resembles the School installation in a couple of ways: the 

installation is handled by a wizard that asks the relevant questions and the teacher 

module is typically installed before any student modules.  

A few things that work differently in the Vision teacher module installation: 

 Vision can be installed as a trial, without a license key. The teacher module will 

stop working after 30 days but can be upgraded to a regular version by entering a 

license key. 

 Decisions about classroom name and student computers are made when the 

teacher module has been installed, not during the actual installation. 

 Your computer will have to be restarted to finalize the Vision teacher module 

installation. 

 Installing the student module on student computers is managed from the teacher 

module, as part of setting up a class. 

3 Vision on first startup 

When the Vision teacher module starts 

after the installation, it has an empty 

classroom with no student computers 

with the default name “Classroom”: 

 

To assist you migrate your Netop School settings to Vision, Vision will search for 

existing Netop School settings on the first startup. If Vision discovers Netop School 

settings on the teacher computer you will be asked whether you want to import these 

settings: 

                                           

1 Note that in this guide the product name “Vision” covers both Netop Vision and Netop Vision Pro. Where 

any reference is related to Vision Pro only this is explicitly mentioned. 
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When you click Now your Netop School settings are imported. 

To be able to see your imported settings Vision needs to be restarted and a message 

is displayed notifying you of this: 

 

After restart of Vision your next step is to ensure that the Vision student module is 

installed on the student computers in your imported classrooms: 

 

Click Install/Update to start the Vision Deployment Wizard which will guide you 

through the process of installing the Vision student module. 

In the “Install / Update Vision Student Software” step, the wizard examines all 

computers listed as student computers in any of the classrooms in Vision and detects 

whether the student module has already been installed: 

 

Once you have confirmed that these are the computers you want the student module 

installed on, the wizard will begin installing on each student computers. 

Note that to be able to install, you need to have administrator rights on the student 

computers. For more information about remote student software installation, see 

page 2 in the Quick Installation Guide. 

http://www.netop.com/fileadmin/netop/resources/products/education/vision/manuals/NetopVisionQuickInstall_EN.pdf
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If you click Cancel when asked to install or update student software, you will have to 

use a different method to ensure that the student software has been installed on 

student computers, for example using Classroom Manager. 

When student computers have been updated you can review the imported settings: 

Classrooms 

(File > Classroom Manager) 

You will see that your imported 

classrooms appear under Personal 

Classrooms. 

The fact that the classrooms appear 

under Personal Classrooms means 

that the classrooms can be used by you; 

other user who log on with their own 

credentials will not be able to see the 

classrooms. 

To connect to one of your newly 

imported classrooms, select the 

classroom and click Open. 

  

Resource lists and block lists2 

(Home > Filter Web > Filter Manager) 

You will see that your Netop School 

Internet policies have been imported as 

block lists or as resource lists.  

Which type they have become in Vision 

depends on the Internet access strategy 

you had defined in Netop School: Allow 

All with exceptions will generate a Vision 

block list. For example: Allow all, except 

Facebook and Youtube will become a 

block list. 

Deny All with exceptions from Netop 

School will generate a Vision resource 

list. For example: Deny all, except three 

sites relevant for an assignment will 

become a resource list. 

If you have Vision (and not Vision Pro) 

any Allow All policies from Netop School 

will be ignored. 

  

Applications that can be started from 

Vision 

(Home > Start Application) 

You will see the any programs you had 

added to Run My Programs in Netop 

School (Teach > Run) are now available 

in Vision also. 

 

About the automated import 

Vision will look for Netop School settings in the standard Netop School folder. The 

exact folder location depends on your operating system; for Windows 7 the folder is: 

C:\Users\<user name>\AppData\Roaming\Netop\Netop School\Teacher 

This means that when John Smith is logged on, Vision will look in: 

                                           

2 Block Lists are available in Vision Pro only 
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C:\Users\johnsmith\AppData\Roaming\Netop\Netop School\Teacher 

This also means that if several teachers are sharing a computer each teacher will 

have to log in to have his or her settings imported. To import Netop School settings 

from another user’s folder you should copy the settings to your own folder; 

alternatively you could use the command-line tool and do the export-import manually 

(see below for more details). 

The import of Netop School settings is performed only once per user; when you have 

imported settings from School into Vision, subsequent changes to Netop School 

settings are not imported. 

Vision searches for Netop School settings on first startup only; if no netop School 

settings are found the search is not performed on subsequent startups.  

If Netop School is not installed on the computer where Vision is installed, the 

automated import cannot take place; this means that you should NOT remove your 

existing Netop School installation prior to installing Vision. 

The automated import impacts the Vision teacher module only: settings are exported 

from the Netop School teacher module and imported into the Vision teacher module; 

the School and Vision student modules are not affected. 

When the import has been completed and Vision is ready for use, Netop School 

teacher and student modules can be uninstalled. 

Importing settings manually 

If you want to import manually, for example if you are an IT administrator who 

manages migration for the entire teaching staff, you can request Netop’s command-

line migration tool from Netop Technical Support. 

The migration tool can: 

 Export settings from Netop School to an .xml file. 

 Import the previously exported .xml file to Netop Vision. 

 Export and import in a single step. 

Note that the tool must be run from a command prompt so you will need to type 

commands and parameters without having a graphical interface. 

You can read more about the tool in the Netop Knowledge Base. 

4 Set up a classroom in Vision 

Adding student computers to a classroom and installing the student module are 

typically handled as one step: provided you have the proper access rights you can 

manage the entire classroom installation from a single computer. 

 

A new classroom is created, edited and 

deleted from the Classroom Manager 

available on the File tab (File > 

Classroom Manager).  

Initially the Classroom Manager has 

only the default, empty classroom. 

Create a new classroom by clicking the 

New button and a wizard will guide you 

through the process. 

 

http://kb.netop.com/article.php?id=236
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The following terms and settings are new in Vision compared to what you are used to 

in School: 

Open enrollment An open enrollment classroom is an alternative to the 

default static classrooms.  

Open enrollment allows teachers to send an invitation to 

join class over the network. Students can accept the 

invitation and join the classroom at any time without 

disturbing other students or the teacher. 

This setting corresponds to the “Be available for any 

class” option which can be set on each student computer 

in Netop School (Tools > Options > Class). By default the 

option is not selected.  

Default classroom The default classroom is the one that the teacher 

computer automatically connects to when Vision starts. 

The name of the default classroom is written in bold text 

in the Classroom Manager. 

Typically Netop School is also set up to start with a 

default class but can be set up so that the teacher has to 

select a class (Options > Class).  

Global classroom If several teachers use the same computers during their 

classes, they can share classroom setup. For several 

teachers to be able to share classroom setup, the 

classroom must be defined as Global. This is the default 

setting when a new classroom is created provided that 

you are logged on as an Administrator. Global classrooms 

can be accessed by any teacher who logs on to the 

teacher computer.  

If you are logged on under a specific user account, any 

classrooms you create are Personal and can be used by 

you only. You cannot convert one type into the other so it 

is important to choose the appropriate setting when you 

create the classroom. 

The concept of a personal classroom corresponds to using 

teacher profiles in Netop School; using global classrooms 

match the Netop School default of not using teacher 

profiles. 

The wizard suggests settings and you can change most of them later. 

In the second wizard step you choose which student computers should be part of the 

classroom you are setting up and the student module is installed remotely. However, 

In order to install on student computers you need full administrative rights to the 

computers; you can either use the credentials you are logged in to the teacher 

computer with or you can specify other credentials. 

Once you have been through these steps, you have set up a classroom and are ready 

to use Vision. 

5 Teaching with Vision 

Like School, Vision has a Ribbon which is organized into a set of tabs that represent 

the main functionality groups. The Ribbon provides one-click access to commands 

with clear, unambiguous labels. 
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Though similarly organized the Vision user interface is simpler in that it has only four 

tabs, making most commands accessible with a single click. 

File tab 

 

The File tab is where you create 

classrooms using the Classroom 

Manager. 

And you use the Options button to 

customize the way Vision looks and 

behaves. 

 

Home tab 

 

The Home tab includes the commands that are the most frequently used, like full-

screen demo, blank screen, lock web, remote control and live view.  

The commands are placed in functionality groups: presentation, controlling, 

supervision and selection. 

One of the basic ideas is that during a typical lesson, the teacher has all the 

commands he or she needs available on a single tab. 

Tip Pointer is a drawing tool that can be useful to highlight areas on your 

screen during a demonstration. You can also zoom in and magnify parts of the 

screen, or spotlight a particular area. 

 

View tab 

 

The View tab is all about different ways to view student computers.  

Tips Shortcut Bar  opens a vertical toolbar of frequently used commands. The 

toolbar can be customized and placed where you find it most useful. The 

toolbar can be particularly useful when you demonstrate an application, like 

for example Excel, and want to have the Vision commands at hand also. 

Chat  is in fact much more than just text chat. In addition to chatting with 

one or more students, you can 

 Send a message to the entire class. 

 Ask questions that students must answer within a time limit. 

 Ask students for feedback. 

 Collect files from student computers, and choose to delete them after 

collection.  

 

Administration tab 
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The Administration tab is where you manage student computers, typically after a 

lesson has ended and you would like either to shut down computer or to re-start 

them to allow new students to log on. 

Tip Using Request name  you can ask student to type their name and display 

this beneath each computer thumbnail to replace login name or computer 

name. 

 
Log On  offers a way for you to log on all student computers so that they 

are ready when students enter the physical classroom.3 

 

  

                                           

3 Log On is available in Vision Pro only 
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Classroom view 

When you start the teacher module Vision automatically connects to your default 

classroom and shows the student computers as thumbnails. This gives you an instant 

overview of what each student is working on and enables you to select one or more 

computers to start using the teaching features. 

 

The Vision screen real estate can be made even larger by minimizing the Ribbon. 

Research has shown that the most frequently used commands in teaching include the 

ones placed on the Home tab: 

 

 

Demo:  Share your screen with the class. 

 Full-screen:  Focus the attention of the class. Lock student 

computers’ keyboard and mouse. 

 Windowed:  Allow student to work while you demonstrate. 

 Minimize:  Students can access your demonstration from the 

taskbar. 

 

Blank Screen:  Get your students’ attention by disabling mouse 

and keyboard while showing a standard picture on their screens. 

 

Lock Web:  Block access to the web on student computers. 

 

Live View:  See what an individual student is working on by 

opening a large, real-time view of his or her screen 
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Remote Control:  Help an individual student by controlling his or 

her computer remotely – just like you were actually sitting in front 

of the computer. 

6 Vision toolbar 

The Vision toolbar offers a way to access the commands in Vision without having the 

main Vision window open. This could be particularly useful in a demo situation where 

the purpose is to show what’s on your screen, not to show the Vision teacher 

module.  

By default the Vision toolbar opens in vertical mode, to the right on your screen. The 

toolbar below is shown horizontally purely for layout purposes: 

 

The toolbar opens with quite a large number of commands but as you begin to use it, 

you can easily add and remove commands according to your usage needs: 

 

The small toolbar above gives you access to these commands: demo, stop all, shut 

down, start application, marker, blank screen, highlight an area and zoom an area. 

7 Customizing Vision 

The main customization options are available from Vision Preferences (File > 

Preferences): 

 

The various areas that can be 

customized are listed to the left. 

Note that the Demo section includes 

a number of options that can be 

turned on or off to optimize screen 

updates depending on what is being 

demoed and what type of network is 

used. 

Another area that can be customized in the 

Quick Access Toolbar at the top of the 

screen: 

As the name indicates the toolbar provides 

easy access to frequently used commands. 

By default the quick access toolbar includes         
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three commands but more can be added. 

The toolbar can also be used to minimize the Ribbon so that only the tab names 

show: 

 

Minimizing the Ribbon means that there will be more screen real estate available for 

the main window with the student thumbnails. 

8 School-to-Vision: map of commands 

Below table lists all commands in School and indicates where you can find the 

corresponding command in Vision.  

For example: the equivalent of the Setup wizard command on the Tools tab in 

School is the Classroom Manager on the File tab in Vision: 

 Netop School  Netop Vision 

Tools > Setup wizard File > Classroom Manager 

 

Complete map 

 Netop School  Netop Vision 

Favorites tab  

Favorites > Entire Screen Home > Demo > Full-screen 

Favorites > Attention Home > Blank Screen 

Favorites > Observe Home > Live View  

Favorites > Deny Internet Home > Lock Web 

Favorites > Allow All Home > Filter Web – Clear All 

Favorites > Chat View > Chat 

Favorites > Record <not available> 

Favorites > Stop Home > Stop 

Teach tab  

Teach > Entire Screen Home > Demo > Full-screen 

Teach > Selected Screen Area <not available> 

Teach > Media file <not available> 

Alternatives:  
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 Netop School  Netop Vision 

Demo a media file using Full-screen 

demo or Windowed demo. 

Start a media file using Start 

Application > Run Application and 

select a video 

Teach > Media file on the Web <not available> 

Alternatives:  

Demo a media file using Full-screen 

demo or Windowed demo. 

Start a media file using Start 

Application > Run Application and 

select a video 

Teach > Recording <not available> 

Teach > Specific Monitor On the File tab, click Preferences and 

in the Demo section, select monitor. 

Now Demo will use the monitor defined. 

Teach > Student Screen Home > Showcase Student 

Teach > Audio-Video Chat <not available> 

Teach > Run Test <not available> 

Teach > Run Survey <not available> 

Teach > Run Program Home > Start Application > Run  

Teach > Run My Programs Home > Start Application > 

<application name> 

Teach > Record <not available> 

Control tab  

Control > Bitmap On the File tab, click Preferences and 

in the Blank Screen section, select a 

file. Now Blank Screen will display the 

selected bitmap file. 

Control > Text On the File tab, click Preferences and 

in the Blank Screen section, type a text 

to display. Now Blank Screen will 

display the text. 

Control > Text File <not available> 

Alternative: 

On the File tab, click Preferences and 

in the Blank Screen section, type a text 

to display. Now Blank Screen will 

display the text. 
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 Netop School  Netop Vision 

Control > Web <not available> 

Control > Reset Policy Filter Web > Clear All 

Control > Allow All <not available> 

Control > Deny All <not available> 

Control > Deny Internet Home > Lock Web 

Control > My Policies Home > Filter Web > Block Lists4 

Home > Filter Web > Resource Lists 

Control > Combine Policies <not available> 

Note that several resource lists can be 

active at the same time. 

Control > Observe Home > Live View 

Control > Remote Control Home > Remote Control 

Manage tab  

Manage > Workgroup <not available> 

Manage > Stop workgroup <not available> 

Manage > Chat  View > Chat 

Manage > Send Message View > Chat > Chat > Send message  

Manage > Distribute View > Chat > Chat > Send message > 

Browse > Send 

Alternative: 

Select computers and click Show 

Document. The selected document 

opens on the student computers and 

they can save locally. 

Manage > Collect View > Chat > Edit > Collect 

Manage > File Manager <not available> 

Manage > Logoff Administration > Log Off 

Manage > Restart Administration > Restart 

Manage > Shutdown Administration > Shut Down 

Manage > Rejoin Administration > Join 

                                           

4 Block Lists are available in Vision Pro only 
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 Netop School  Netop Vision 

Manage > Move Student <not available> 

Tools tab  

Tools > Reannounce Class <not available> 

Tools > Ask Class Server <not available> 

Tools > Change Teacher <not available> 

Tools > Export Module and Data <not available> 

Tools > Import Data <not available> 

Tools > Setup wizard File > Classroom Manager 

Tools > Student Deployment File > Classroom Manager 

Installation program 

Tools > Check updates <not available> 

Tools > Publish updates <not available> 

Options tab  

Options > Demonstrate Partly covered by File > Preferences > 

Demo - but options not as advanced as 

the School options. 

Options > Run Home > Start Application > Manage 

Applications 

Options > Attention File > Preferences > Blank Screen 

Options > Policy Partly covered by Home > Filter Web > 

Manage lists where you can define 

block lists and allow lists – but 

applications cannot be blocked, nor can 

specific ports 

Options > Supervision Partly covered by File > Preferences > 

Remote Control - but options not as 

advanced as the School options. School 

options also cover options for 

Supervise/Live View. 

Options > Class File > Class Manager 

Options > General Partly covered by View > Label Type 

and View > Sort by label 

Options > Advanced Audio-Video Chat options: <not 

available> 

Connection: File > Preferences > 

Network 
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 Netop School  Netop Vision 

Protection: File > Security (not quite 

equivalent) 

Sharing: <not available> 

Teachers: <not available> 

Toolbar commands: Customize quick 

access toolbar (not quite equivalent) 

Web Update: <not available> 

 

 

Options > Personalize <not available> 

Options > Custom <not available> 

Help tab  

Help > Contents Help 

Help > Online support <not available> 

Help > Online registration <not available> 

Help > Apply license Start > Netop Vision > Licensing Utility 

Help > Save log <not available> 

Help > About File > Preferences > General 

 


